Life with Baby K

June 26, 2008

After 3 Days of stims….

Filed under: Uncategorized — by Jess @ 10:36 am
Tags:

My estrogen level was only 79!!! ARE YOU FREAKIN KIDDING ME???? I went on Tuesday, which was actually two days before I was originally suppose to have bloodwork but the doc decided he wanted to watch me closer since my last cycle was so screwy. Sounds good to me and I am glad that they had me in on Tuesday. So the nurse (my favorite nurse named Ellen) called and told me that they wanted me to change how I give my meds. I am now doing two shots, one in the morning and one in the evening. I am still at the same amount of meds, just cut and half and given twice. They are wondering if I am metabolizing the meds too quickly or something.  So apparently shooting up twice a day is suppose to help that. I go back in the morning for bloodwork and ultrasound. Hopefully something is cooking inside of me!!!

So my mind keeps going to the dark place and wondering what the hell I am going to do if my body continues to not respond to meds. I mean for crying out loud this is suppose to be the easy part of the process! The fertilization is suppose to be the challenge, not producing the eggs! We haven’t even gotten to the hard part yet! I mean, what am I suppose to do if this doesn’t work out???

Advertisements

Leave a Comment »

No comments yet.

RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at WordPress.com.

%d bloggers like this: